US Region: Planning intermittently slow to load

Incident Report for IBM Apptio

Resolved

Performance has stabilized, and we have not observed any further issues. This incident is now being closed as resolved.
Posted Mar 18, 2026 - 19:49 UTC

Monitoring

We have mitigated this issue and are currently monitoring the performance.
Posted Mar 18, 2026 - 18:08 UTC

Investigating

We are currently investigating reports of slow performance impacting the Planning application for customers in the US region. Our engineering teams are actively working to identify the issue and restore normal performance as quickly as possible.
Posted Mar 18, 2026 - 17:41 UTC
This incident affected: Americas (US) - AWS (Planning).